
Geographic Information Systems Modules
Spring 2016

Center for Digital Scholarship
University of Notre Dame

Matthew L. Sisk

Demo 09: Layouts and Map Composition

A critical part of GIS is effectively transmitting your results.  Often, a good project is destroyed by a bad 
final product.  Thus, this demo is designed to show you how to create final maps that effectively present spatial 
data.  In contrast to most earlier demos, these notes serve less as a step-step instruction and more as a reference
for how to do certain tasks.

I. Prepare the Demo data
a. There is a Demo09_Data.zip file

1. You can use it to follow along with what I am doing in the demo, but otherwise you should use your 
own data.

II. Data vs. Layout View in ArcMap
a. ArcMap allows you to view your data in two ways, “Data View” (which we have been using up until now) 

and “Layout View” (which is what you would use to actually produce printable maps).
b. There are two ways to switch between views:

1. At the top of the main window click View - the first two choices are “Data View” and “Layout View”.
2. At the bottom left corner of the viewing window (NOT the table of contents but

just the window containing the actual data) there are two buttons which
correspond to the two view modes.

c. Layout View is similar to “Print Preview” in a word processing program; you can see your map positioned 
on a sheet of paper.

d. The layout automatically has one “Data Frame” (i.e. map) for every Data Frame your project has.  In 
addition, you can add tables and charts to the layout, as well as map elements such as scales, legends, 
and north arrows.

e. The Layout View has a corresponding toolbar:
1. The navigation tools allow you to

pan and zoom around the page
preview; 

2. Note that the data remains at the same scale; to change the scale and pan the actual data 
layers, use the main navigation tools.

III. Working with layouts
a. Make sure you are in Layout View.
b. Page Setup 

1. The page setup dialog allows you to set various page size and print quality variables
2. Select File → Page Setup to display the dialog window.

i. The map page size (as seen in the layout window) can be set independently from the Paper 
Setup, but this can be confusing.  It is recommended that you check the Use Printer Paper 
Settings box under Map Page Size, and make all adjustments in the Paper area of the window.

ii. If you were printing hard-copies you would set the printer here
iii. Orientation refers to whether the long axis of the page is horizontal or vertical.  If your geographic 

area extends further EW than NS, you might want to set orientation to Landscape.
3. Click OK to close the Page Setup window when you have finished.

IV. Adding map elements
a. Scale bar

1. Understanding the scale of geographic data is crucial for the
map to be interpretable by a user.  All maps should indicate
scale, whether by a scale bar, scale text, a coordinate grid or
some combination of the three (see below for the latter two). 

2. In Layout View select Insert → Scale Bar.  
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i. Note that if your have set the display units in the General tab of the Data Frame properties they 
should be the default here.

3. Choose a style and click OK.  The scale bar will be visible on the layout.
4. Drag it to an appropriate position.
5. Right-click it and select Properties.  There are a lot of options to be set in

this dialog, and you should experiment with their effects on the display of the
scale bar.  The most important is the Scale and Units tab:
i. It is strongly recommended that When resizing… is set to Adjust

Width or Adjust number of divisions.
ii. The Division value is the main interval of the bar;
iii. The Number of divisions is the number of intervals;
iv. The Number of subdivisions only affects only the first division, which

can be broken down into subdivisions if this number is not zero.
v. The other tabs set other properties such as font color and size,

background and border, etc.
6. An alternative to a scale bar is Scale Text

i. Scale text can be added through the Insert menu as was the scale bar.
ii. Bear in mind that Scale Text refers to the scale of the map as printed; if you were to photocopy 

the map with reduction or enlargement, the scale text would be inaccurate.  This is one reason 
why a scale bar is preferable (or should at least accompany scale text).

b. Legends
1. In Layout View, select Insert→Legend.  The Legend Wizard will start. 
2. In the first section of the wizard, choose which map are to be included in the legend and their order.  

i. You should remove any layers which are not displayed, or which can be intuitively understood, 
such as contour lines.

ii. You have the option of spreading out the legend over more than one column.  This is advisable if
your map layout has more horizontal space available.

iii. Click Next.
3. Set the legend title, font properties, and alignment (if you choose to have a title for your legend).  

Click Next.
4. Choose a border, background and drop shadow.   Background is important, especially if your legend 

will be stacked atop your Data Frame.  The Gap determines the distance between the border and 
the text of the legend.  Click next.

5. For each layer to be included in the legend, choose the size and shape of the “symbol patch” used 
to represent lines and polygons.  Click Next. 

6. Set the spacing between different parts of the legend.  In general, use the defaults.  To see exactly 
where the spacing is, put the cursor in the box and the spacing will be highlighted in red on the right 
side of the window.  Click Finish.

7. Any of these settings can be changed by right-clicking on the legend and selecting Properties.
c. North arrow

1. In Layout View ,  select Insert → North Arrow.
2. Choose a style and click OK.  The arrow will appear on your map.  You can move it or rescale it by 

dragging it or one of its corners.
3. The direction of the arrow will reflect the rotation of the map (in the General tab of the Data Frame 

Properties).
d. Map title and other text

1. Select Insert → Title.  A text box will appear; you can begin typing in your title immediately.
2. Position it on the layout.  To change the text or style, right-click it and select Properties.
3. You can also insert other text (Insert→Text).  Other information that might be included on the map:

i. Projection and Datum information;
ii. Source(s) of data and their date(s);
iii. Labels on the map

4. Text graphics can also be added  using one of the tools in the Drawing toolbar
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i. Access the alternate text tools by clicking on the leftmost A.
a. The standard text tool is identical to section 3 above;
b. The Splined text tool allows for curving text (excellent for labeling rivers or other curving 

features);
c. The Callout text tool puts text in a box which has a callout line, making a connection 

between the label and the feature it labels.
d. The text tools with polygon, square, or circle allows text to flow across multiple lines, within 

the shapes drawn
e. Arranging map elements on the Layout

1. The Layout View also has a lot of Adobe Illustrator-like tools for moving and arranging elements
2. Clicking on a map element will select it; you can then drag it to position it on the Page (layout) or 

drag sides and corners to change its size.
3. Note that most elements can be further modified by right-clicking them and selecting Properties.
4. Stacking elements on the layout

i. As with layers on a map, some elements of a layout may obscure others, so the stacking order 
is important.

ii. Right-click on any element in the layout and select one of the choices under Order
a. The selected map element can be moved to the top or bottom of the stack, or moved up or 

down incrementally.
b. In general, you will want your Data Frame to be at the bottom of the stack.
c. If  you will have all elements non-overlapping, order will not be crucial.

5. Order and arrange the map elements on the layout.  Remember to leave room for the scale, north 
arrow and legend.

6. Aligning and distributing
i. Two other useful layout functions are Align and Distribute, both available by right-clicking after 

selecting two or more map elements (by holding down shift while you select),
ii. The choices under Align places elements on the layout with relation to the other selected 

elements;
iii. Distribute will space elements evenly in the horizontal or vertical direction.

f. Grid marks
1. You can also add a grid around the outside of your map to show known coordinates
2. Do this by first going into the Data Frame Properties

i. Either right-click or double-click on Layers in the Table of Contents
3. From here you should go to the Grids tab
4. Choose New Grid

i. You have the choice of Graticule, Measured or Referenced
Grid
a. Graticule is Latitude/Longitude
b. Measured is based on map units (usually meters)
c. Reference is an index grid

1. I never have gotten this one to work right
ii. You can have any number of different grids
iii. Also, even if your map is in UTM, you can have Lat/Long

grids, and vice versa
iv. You can give each one of the grids a name here too

5. After you choose your grid type choose, Next
i. Appearance will let you set if the coordinates have lines

drawn across the map, only labels or little marks where they cross.
ii. Intervals shows how frequently your coordinates are marked.  This will depend on the size of 

your map.
6. You can set several other things relevant to the appearance of the grid, but for now, just hit next a 

few more times and then finish.
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i. If you need to go back and edit, you can go back into the Data Frame Properties and double-
click on the name of your grid.

V. Adding Tables and Graphs
a. You can also add premade tables and graphs to your layout.
b. To add a table, or the attribute table of a shapefile

1. Open it.

2. Click on the Table Options ( ) button and choose Add Table to Layout
3. Once you do this a copy of the table as it is now will be put on the Layout.  You can't change the 

display.
4. Thus, you may want to make the table pretty before putting it on the layout.

i. You can right-click on field names to
a. Turn the field off (useful for FID or Shape fields)
b. Enter the properties and change the Alias, or how the field name is displayed.

ii. Adjust the width of the columns
5. Adding summary tables (like we have made previously) to the layout is useful.

c. Adding Graphs.
1. We can also give any pop-up graphs a permanent place on the page layout
2. For example, if you make a profile like we did in Demo 8 Section VII you can then add it onto the 

layout by right-clicking on the blue bar at the top and choosing Add to Layout
i. Before you do this you may want to choose Properties and change the Titles and Labels on the 

Appearance Tab.
ii. Also, remember that this may not work if you have not enabled the Spatial Analyst extensions in 

Customize → Extensions
d. Making new Graphs.

1. You can also make new graphs from any of your tables.  

i. In the Attribute Table, click on the Table Options ( ) button and choose Create Graph
a. You have a tremendous number of options in here.  
b. We're not going to spend a lot of time with making graphs, but I encourage you to 

experiment with these.
2. You would then add a new graph to the layout by clicking on the Blue Bar and choosing Add to 

Layout.

VI. Printing / Exporting the map 
a. When you have a finished map you have two main options: print your map to the printer (hardcopy map) 

or export it as a digital image (JPG, TIF or PDF formats).
b. Preview what the map will look like by selecting File→Print Preview.
c. We are not going to print hard copies, but the way to do so is very easy (File → Print).
d. Exporting the map as an image:

1. You may wish to have a digital version of the map; some examples of why include:
i. Publication on the web;
ii. Publication in a printed form (e.g., a book or academic journal);
iii. Presentation imagery (i.e., digital projection at a conference)

2. To do this, make sure you are in Layout View and select File→Export Map.  
i. Give your image a name and choose the type of file to export;
ii. Choosing your file type: this depends on the ultimate purpose of the map

a. For print publication, TIF is the best quality, and should not be less than 300 dpi (under 
Options).

b. For projection and the web, JPEG is the best option, generally at 150-200 dpi; at 8.5x11”, 
most LCD projectors can’t show any further detail than this.

c. If your map contains only vector data layers, you can export your map as PDF, 
Encapsulated PostScript (EPS) or Adobe Illustrator (AI) formats; in many cases these 
formats produce small files which can be read by and printed from Adobe Acrobat with 
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fantastic sharpness.
iii. On the General tab under the Options at the bottom of the window, choose the appropriate 

resolution;
iv. On the Format tab, choose your color mode.  If you are exporting an image with only black and 

white, choose 8-bit grayscale as the color mode (also if your image will be printed in a B&W-only
publication).  Grayscale files are much smaller.

v. Make sure that Clip Output to Graphics Extent is checked; otherwise your output image will have
a very large white margin.

e. I expect to see JPEG versions of maps with various map elements (scale bars, etc.) for this weeks 
assignment and in your final papers and PowerPoint slideshows.
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